checking for APR... configure: error: the --with-apr parameter is incorrect

18.05.2010, рубрики: FreeBSD, Новости | Теги: , , , | 5 комментариев »

Решил обновить Apache 2.2.14 до версии 2.2.15. Столкнулся с проблемой, не обновлялся, обновление вылетало с ошибкой во FreeBSD:
checking for APR... configure: error: the --with-apr parameter is incorrect

Решил проблему так:

1
2
3
# cd /usr/ports/devel/apr1
# make deinstall clean
# make config

Поставил галочку напротв thread

1
2
3
4
# make install clean
# cd /usr/ports/www/apache22
# make deinstall clean
# make reinstall clean

После этого Apache обновился без проблем.


5 комментариев на запись “checking for APR... configure: error: the --with-apr parameter is incorrect”

  1. 1 Fire_Anton сказала в 2:53, 05.07.2010:

    Большее спасибо. Очень помогло.

  2. 2 Влад сказала в 16:29, 22.08.2010:

    Спасибо! Только у вас нашел. Апач собираться не хотел...

  3. 3 Александр сказала в 14:36, 01.09.2010:

    Спасиб, реально помогло. Процесс сборки не прервался! :)

  4. 4 Soft_RaideR сказала в 1:50, 20.12.2010:

    Обновлял сервер(до 7.3, с 6.0) который жил со времен 5.4 фри, пришлось снести все apr, и потом только получилось с апачем разобраться, но куда копать статья натолкнула правильно. За что спасибо!

  5. 5 Serg сказала в 16:44, 18.01.2011:

    Большое человеческое СПАСИБО


Оставить комментарий


  • + 7 = двенадать